Redmi 1s Stuck at Mi Logo [Solved]

Hello Redmi 1s Users,
Having Trouble with your device? Stuck on the booting, stopped at Mi logo?
i am here with the solution for redmi 1s devices booting problem,
First of all you need to know that what happens to your device, actually this is not a very common problem, sometimes when you want to upgrade your device to any other version of MIUI it gets stuck because of some errors.
bricked redmi 1s

Here is the step by step guide to get ride from this problem.
First Download these files to your PC :
1 - MiFlash Tool : Download here
2 - Full Fastboot MIUI ROM For Redmi 1s : Download here

As you downloaded both the file then Extract the ROM file into C:/ drive
and Install the MiFlash Tool on the desktop And RUN the program


Now in the Miflash Tool click on the browse button and select the image folder which you have extracted on the C:/ Drive


After this turn off your Redmi 1s and enable Fastboot Mod by Pressing Volume Down+Power Button Simultaneously and connect your device to PC using Data Cable
Now click on the Refresh button to get your device displayed on the tool.


Now Just click on the Flash Button and it will start flashing your device, wait until the process bar get green, it confirms that you have successfully flashed Rom into your phone, and your device will reboot by itself.
Yahhoo  Now Redmi 1s is all set. For Rooting Redmi 2 Read this Post.
and please share this post if you think its helpful.

SHARE

Naman Dwivedi

Hi Friends ! Welcome to AndroWide.com, i'm Naman a Tech Blogger and Passionate About Android Devices, So i Started This Blog To Help Out People Who Facing Some Issues or Looking For New Tricks Related to Android. Join AndroWide on Social Media to Get Latest Tips and Tricks of Android Phones. Like Us on Facebook, Subscribe our YouTube Channel To Get Latest Tips and Tricks of Android, and Follow us on Twitter

    Blogger Comment
    Facebook Comment

1 comments:

Jaipaul Jeyakumar Thevar said...

Sir my Redmi 1s continously flash mi logo even after switching on after battery removal, it switches on by itself, please help me